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1. Pendahuluan 
 

Macromedia Flash menyediakan tools yang digunakan untuk menggambar. Tools tersebut tersedia 
pada panel Tools yang terletak di sebelah kiri stage. Salah satu tool yang digunakan untuk membentuk 
suatu objek adalah Pen Tool. Bagi para pemula, penggunaan Pen Tool terasa sulit. Mereka lebih memilih 
menggambar menggunakan tools lainnya seperti Pencil Tool atau Line Tool.  

Penggunaan Pen Tool memang memerlukan banyak latihan dan kecermatan. Selain itu diperlukan 
pengetahuan dasar mengenai cara penggunaan Pen Tool. Dalam artikel ini penulis akan menyajikan cara-
cara dasar penggunaan Pen Tool pada Macromedia Flash. 
 
 
2. Cara Kerja Pen Tool  
 

Pen Tool digunakan untuk menggambar garis lurus atau garis lengkung kemudian mengatur sudut, 
panjang, dan kemiringannya. Pendek kata, Pen Tool digunakan untuk membentuk suatu bentuk dasar 
(outline) dengan ketepatan yang diharapkan. 

Jika stroke (outline) suatu objek diseleksi menggunakan Pen Tool maka outline objek tersebut akan 
berubah menjadi suatu ruas garis lurus atau lengkung yang dihubungkan oleh beberapa titik. Titik-titik 
penghubung ini dinamakan anchor points .  
 
Contoh 1 : 
 

1. Klik Oval Tool . 
2. Pilih stroke color dan fill color. Gambarkan sebuah lingkaran pada stage. 

3. Klik Pen Tool . 
4. Klik stroke (outline / garis luar) pada objek lingkaran yang tadi telah dibuat. Perhatikan bahwa 

stroke objek lingkaran berubah menjadi garis -garis lengkung yang terhubung oleh titik-titik 
(anchor points). Hal demikian juga akan terjadi ketika stroke suatu objek diseleksi menggunakan 
Subselection Tool. 

 
 

Lisensi Dokumen: 
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dan pernyataan copyright yang disertakan dalam setiap dokumen. Tidak diperbolehkan melakukan 
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Gambar 2.1 
 

5. Cobalah pada bentuk-bentuk selain lingkaran, misalnya pada garis lurus atau pada persegi empat. 
 

Cara kerja Pen Tool dalam menggambar garis lurus berbeda dengan cara kerjanya dalam 
menggambar garis lengkung.  
Cara membuat suatu garis lurus dengan Pen Tool : 

1. Klik Pen Tool. 
2. Klik satu kali pada stage untuk membuat titik acuan awal (anchor point). 

 
Gambar 2.2 

 
1. Selanjutnya buatlah anchor point yang kedua. Caranya, klik mouse satu kali pada stage sambil 

menekan tombol Shift pada keyboard secara bersamaan. Tujuan menekan tombol Shift agar ruas 
garis yang terbentuk diantara dua anchor point dapat berupa garis lurus atau garis dengan 
kemiringan 45 derajat dan kelipatannya. 

 
Gambar 2.3 

 
3. Terbentuk garis lurus. Setiap kali selesai menggambar suatu objek menggunakan Pen Tool, klik 

tools selain Pen Tool untuk dapat melihat bentuk objek yang terjadi. 

 
Gambar 2.4 

 
Sedangkan untuk membuat garis lengkung : 

1. Klik Pen Tool. 
2. Klik satu kali pada stage, tahan dan seret mouse ke arah kelengkungan kurva yang diinginkan. 

Pada saat mouse diseret pada stage, muncul garis singgung (tangent handles) sebagai arah acuan 
kelengkungan. 

 
Gambar 2.5 

 
3. Lepaskan mouse. 
4. Posis ikan mouse di tempat yang Anda inginkan untuk anchor point kedua. Klik mouse satu kali 

sambil ditahan dan digeser ke arah yang dapat menghasilkan bentuk kurva yang diinginkan. 

 
Gambar 2.6 

 
5. Lepaskan mouse. Klik tools selain Pen Tool untuk melihat objek yang terjadi. Garis lengkung yang 

dihasilkan seperti tampak pada Gambar 2.7. 

 
Gambar 2.7 
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Perhatikan :  

Pada saat mouse Anda letakkan di stage, pada bagian bawah Pen Tool terdapat simbol X (Gambar 
2.8). Artinya anchor point yang akan Anda buat adalah anchor point pertama dan dapat diletakkan di 
sembarang bagian stage. 

 
Gambar 2.8 

 
 
3. Preferences Pada Pen Tool 
 

Flash menyediakan preferences untuk Pen Tool. Preferences ini bertujuan memberi kemudahan 
dalam penggunaan Pen Tool. Klik menu Edit > Preferences, ke mudian klik pada Editing tab . Pada bagian 
Pen Tool terdapat tiga buah option  yaitu, show pen preview, show solid points, dan show precise cursors. 

 

 
Gambar 3.1 

 
Fungsi dari masing -masing option adalah : 
Show pen preview: untuk memperlihatkan preview dari garis yang akan terbentuk ketika mouse diarahkan 

dari suatu anchor point menuju ke tempat dimana anchor point berikutnya akan 
dibuat. 

 

Show solid points: klik Subselection Tool . Klik pada stroke suatu objek untuk menyeleksinya. 
Stroke pada objek berubah menjadi ruas-ruas garis beserta anchor points. Klik satu 
kali pada salah satu anchor point untuk menyeleksinya. Jika option show solid points 
diaktifkan, anchor point yang diseleksi akan tampak sebagai lubang kecil. Sedangkan 
anchor point yang tidak terseleksi ditampilkan sebagai titik penuh (solid). Sebaliknya 
jika option ini tidak diaktifkan, maka anchor point yang diseleksi akan tampak seperti 
titik penuh sedangkan anchor point yang tidak terseleksi ditampilkan sebagai lubang 
kecil. 

 
Show precise  
cursors: jika option ini diaktifkan, pointer Pen Tool pada stage akan ditampilkan sebagai 

simbol X (tanda silang). 
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4. Menggambar Objek Dengan Outline Garis Lurus 
 

Sebelum mulai menggambar, aktifkan terlebih dahulu option show pen preview pada preferences  
untuk memudahkan penggunaan Pen tool. Caranya, pilih menu Edit > Preferences  kemudian klik Editing 
tab. Selanjutnya klik satu kali pada simbol kotak kecil disebelah kiri option show pen preview . 

 

 
Gambar 4.1 

 
 

Contoh 2 : Menggambar bentuk polygon 
 
Mempersiapkan stage 

 
1. Buka flash document baru (pilih menu File > New). 
2. Untuk memudahkan menentukan letak-letak anchor points diperlukan bantuan grid. Aktifkan grid  

dengan cara pilih menu View > Grid > Show Grid. Kini stage dipenuhi oleh garis -garis melintang 
dan membujur yang membentuk kotak-kotak kecil. Garis -garis inilah yang disebut grid. Panjang 
dan lebar kotak-kotak grid dapat diatur melalui menu View > Grid > Edit Grid. 

3. Selanjutnya aktifkan option snap to grid. Caranya, klik menu View > Snapping > Snap to Grid. 
Jika disamping option snap to grid sudah terdapat tanda cek ( ) artinya option snap to grid telah 
aktif. 

 
Menggambar polygon 
 

1. Klik Pen Tool. Arahkan mouse pada sudut salah satu kotak grid  di stage. Selanjutnya klik mouse 
satu kali untuk membuat anchor point pertama. Polygon merupakan gabungan ruas-ruas garis lurus 
maka untuk membuat anchor point pertama cukup klik satu kali pada stage. 

 

 
Gambar 4.2 

 
2. Geser mouse ke kanan lalu klik mouse satu kali untuk membuat anchor point kedua. Perhatikan 

bahwa walaupun arah mouse Anda tidak tepat berada pada salah satu sudut grid, tetapi anchor 
point kedua tetap terjadi di salah satu sudut grid. Inilah fungsi dari option snap to grid, yaitu 
menjadikan sudut-sudut grid  sebagai magnet bagi arah mouse Anda. 

 

 
Gambar 4.3 

 
3. Tarik mouse ke arah bawah kanan sebesar 45 derajat lalu klik satu kali untuk membuat anchor 

point ketiga. 
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Gambar 4.4 

 
4. Lanjutkan membuat anchor point keempat, kelima dan seterusnya hingga membentuk segi 

delapan. 
 

 
Gambar 4.5 

 
5. Pada saat anchor point terakh ir selesai dibuat yaitu tepat pada posisi anchor point yang pertama, 

secara otomatis objek segi delapan akan terisi oleh warna. Klik tools selain Pen Tool untuk melihat 
objek yang terjadi. 

 
 

 
 
 
 
 
 
 
 
 

Gambar 4.6 
 
 
5. Menggambar Objek Dengan Outline Garis Lengkung  
 

Persiapan stage sama dengan persiapan pada saat menggambar bentuk polygon pada Contoh 2. 
 
Contoh 3 : Menggambar bentuk elips 
 

1. Persiapkan stage seperti pada Contoh 2. Jangan lupa untuk mengaktifkan grid dan Snap to Grid. 
2. Klik Pen Tool, arahkan mouse pada stage. 

 

 
Gambar 5.1 

 
3. Klik mouse satu kali sambil ditahan dan digeser ke arah kanan sebesar satu kotak grid, sehingga 

muncul tangent handles seperti tampak pada Gambar 5.2. 
 

 
Gambar 5.2  
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4. Lepaskan mouse. 
5. Arahkan mouse ke kanan sebesar lima kotak grid dan kebawah sebesar satu kotak grid seperti pada 

Gambar 5.3. 
 

 
Gambar 5.3 

 
6. Klik mouse satu kali sambil ditahan dan digeser kebawah sebesar satu kotak grid . Lepaskan 

mouse. 
 

 
Gambar 5.4 

 
7. Arahkan mouse kebawah sebesar satu kotak grid dan ke kiri sebesar lima kotak grid seperti pada 

Gambar 5.5. 
 

 
Gambar 5.5 

 
8. Klik mouse satu kali sambil ditahan dan digeser kekiri sebesar satu kotak grid. Lepaskan mouse. 

 

 
Gambar 5.6 

 
9. Arahkan mouse kekiri sebesar lima kotak grid dan ke atas sebesar satu kotak grid seperti pada 

Gambar 5.7. 
 

 
Gambar 5.7 

 
10. Klik mouse satu kali sambil ditahan dan digeser keatas sebesar satu kotak grid. Lepaskan mouse. 

 

 
Gambar 5.8 

 
11. Terakhir, arahkan mouse pada anchor point pertama sehingga muncul tanda bulatan kecil dibawah 

simbol Pen Tool. Kemudian klik mouse satu kali. Tanda bulatan kecil pada Pen Tool 
mengisyaratkan bahwa posisi mouse sudah tepat untuk membuat anchor point terakhir untuk 
menutup kurva. Setelah kurva tertutup, secara otomatis objek elips terisi oleh fill warna. 

   
 
 
 

Gambar 5.9 
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12. Klik pada tools selain Pen Tool untuk melihat hasilnya. 

 

 
Gambar 5.10 

 
 
6. Menggunakan Pen Tool Bersama Subselection Tool 
 

Subselection Tool merupakan salah satu tool pada Flash yang digunakan untuk reshape (mengedit) 
suatu shape atau ruas garis. Subselection Tool juga menggunakan anchor points dalam melakukan reshape. 

Dikenal dua jenis anchor points yaitu curve point dan corner point. Ketika Anda menggambar 
sebuah garis lengkung, artinya anchor point yang Anda buat merupakan curve point. Sedangkan corner 
point merupakan anchor point pada ruas garis lurus. Curve point ketika diseleksi nampak sebagai lingkaran 
kecil sedangkan corner point nampak sebagai kotak kecil. 

Jika Anda mengubah suatu garis lurus menjadi garis lengkung artinya anda mengubah corner point 
menjadi curve point , demikian pula sebaliknya. 

 
 

 
 

Gambar 6.1 
 
 

 
 
 
 

Gambar 6.2 
 

Contoh 4 : Menggambar bentuk hati 
 

1. Persiapkan stage sama dengan persiapan stage pada Contoh 2 dan Contoh 3. 
 

2. Klik Line Tool . 
3. Arahkan mouse pada stage dan gambarkan bentuk objek seperti pada Gambar 6.3 dengan 

menggunakan Line Tool. 
 
 
 
 
 

 
Gambar 6.3  

 
4. Bentuk dasar pada Gambar 6.3 akan diedit menggunakan Subselection Tool sehingga menjadi 

gambar hati. 
5. Klik Subselection Tool. Kemudian klik mouse pada objek. 
6. Objek berubah menjadi ruas -ruas garis lurus yang dihubungkan oleh anchor points. 

 

Corner point 

Curve point 
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Gambar 6.4 

 
7. Anchor points pada objek merupakan corner points karena objek berupa ruas -ruas garis lurus. 

Untuk dapat mengubah objek tersebut menjadi berbentuk hati, ada dua corner point yang akan 
diubah menjadi curve point . 

 
Merubah corner point  pertama menjadi curve point : 
 

8. Arahkan mouse pada corner point paling kiri. 
 

 
Gambar 6.5 

 
9. Klik mouse satu kali pada corner point tersebut untuk menyeleksinya. Sehingga berubah menjadi 

kotak kecil tertutup. 
 

 
Gambar 6.6 

 
10. Selanjutnya tekan tombol Alt pada keyboard sambil gunakan mouse untuk menggeser corner point 

tersebut ke kiri sebesar dua kotak grid , tahan mouse dan sambil tetap menekan tombol Alt 
lanjutkan dengan memutar mouse searah jarum jam. 

 
 
 
 
 
 
 
 

Gambar 6.7 
 

11. Lepaskan mouse dan tombol Alt pada keyboard. 
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Merubah corner point  kedua menjadi curve point : 
 

12. Klik corner point  paling kanan untuk menyeleksinya. 
 

 
Gambar 6.8 

 
13. Tekan tombol Alt pada keyboard sambil gunakan mouse menggeser corner point tersebut ke kanan 

sebesar dua kotak grid, tahan mouse dan sambil tetap menekan tombol Alt lanjutkan dengan 
memutar mouse berlawanan arah jarum jam. 

 
 
 

 
 
 
 
 

Gambar 6.9 
 

14. Sekarang bentuk objek menjadi seperti pada Gambar 6.10. 
 

 
Gambar 6.10 

 

15. Klik Paint Bucket Tool . 
16. Selanjutnya pilih color fill untuk mewarnai objek hati. 

 

 
Gambar 6.11 

 
Ada kalanya dalam melakukan reshape suatu objek Anda harus menambahkan, menggeser dan 

menghapus suatu anchor point. Untuk menambahkan anchor point, klik ruas garis menggunakan Pen Tool. 
Kemudian arahkan mouse pada ruas garis tersebut sampai terlihat simbol + dibawah pointer Pen Tool, lalu 
klik satu kali pada tempat tersebut. Jika tanda + tidak muncul artinya anda tidak dapat menambahkan 
anchor point pada ruas garis tersebut. 
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Gambar 6.12 
 
Sebelum menghapus suatu anchor point, perhatikan apakah point tersebut berupa corner point atau 

curve point. Untuk menghapus corner point cukup klik sekali pada point dengan menggunakan Pen Tool. 
Sedangkan untuk menghapus curve point, klik dua kali pada point dengan menggunakan Pen Tool. 

Untuk memindahkan anchor point gunakan Subselection Tool. Klik anchor point yang dimaksud 
kemudian geser dengan mouse. Atau dapat juga dengan cara klik anchor point dengan Subselection Tool 
kemudian gunakan tombol anak panah pada keyboard (arrow keys) untuk mengatur perpindahannya. 
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