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About the document  

A. Copyright  

This document is copyrighted (c) 2003 ArtiVisi Intermedia. Permission is 

granted to copy, distribute and/or modify this document under the terms of the 

GNU Free Documentation License, Version 1.2 or any later version published 

by the Free Software Foundation; with no Invariant Sections, with no Front-

Cover Texts, and with no Back-Cover Texts. A copy of the license is available 

at http://www.gnu.org/copyleft/fdl.html  

B. Disclaimer 

No liability for the contents of this documents can be accepted. Use the 

concepts, examples and other content at your own risk. As this is a new 

edition of this document, there may be errors and inaccuracies, that may of 

course be damaging to your system. Proceed with caution, and although this 

is highly unlikely, the author(s) do not take any responsibility for that. 

You are strongly recommended to take a backup of your system before major 

installation and backups at regular intervals.  

C. Version 

Revision : 1.0.1 

Date : April 2003 

The latest version of this document is available on 

http://courseware.artivisi.com 

D. Knowledge Required  

The readers are assumed to have basic knowledge on Windows Operating 

System. 



E. Feedback and corrections 

If you have questions or comments about this document, please feel free to 

mail us at support@artivisi.com. We welcome any suggestions or criticisms.  

Thanks. 



 

 1 

About the authors 

Endy Muhardin 

Lahir di Jakarta, 8 Juni 1979. Lulus dari SMUN 81 Jakarta Timur 

pada tahun 1997 dan melanjutkan ke Teknik Industri STT 

Telkom. Di masa kuliah salah pergaulan sehingga terkena 

wabah Linux-PHP-MySQL. Selain itu, aktif dalam berbagai 

organisasi mahasiswa seperti Himpunan Mahasiswa Teknik Industri STT 

Telkom dan Senat Mahasiswa STT Telkom. Pada tahun 1999 ikut terlibat 

mendirikan start-up company Telematics Indonesia 

<http://www.telematicsindonesia.com>. Menyelesaikan kuliah pada tahun 

2001, meninggalkan Telematics Indonesia yang sedang direstrukturisasi, dan 

hijrah ke Surabaya.  

Saat ini bekerja sebagai trainer di Aptech Computer Education dengan 

spesialisasi Java, Linux, dan PHP. Selain itu juga aktif sebagai dosen luar di 

STIKOM Surabaya untuk matakuliah Pemrograman Berorientasi Objek 

dengan Java dan Aplikasi Internet II.  

Tulisan yang dihasilkan antara lain, Modul Pelatihan PHP Programming, 

Modul Praktikum Java Fundamental, Modul Praktikum Java Distributed, dan 

berbagai materi lain yang dapat didownload di http://courseware.artivisi.com  

Aktivitas utama saat ini adalah menginkubasi perusahaan start-up ArtiVisi 

Intermedia <http://www.artivisi.com>.  

Penulis dapat dihubungi melalui email endy@artivisi.com 

 

 



 

 2 

I. Pengenalan Fireworks 

A. Apa itu Fireworks 

Fireworks adalah aplikasi desain grafis yang dikhususkan untuk 

membuat website. Sesuai dengan definisi tersebut, Fireworks lebih 

diutamakan penggunaannya untuk desainer website dengan latar 

belakang keahlian desain grafis, yang melibatkan perangkat image 

editing, seperti Adobe Photoshop ataupun Corel Draw. 

Fitur-fitur yang tersedia di Fireworks disesuaikan dengan latar belakang 

skill image editing, diantaranya adalah : 

 Kemampuan mengedit berbagai jenis image dalam satu aplikasi. 

 Kemampuan membuat efek animasi pada image 

 Kemampuan mengedit image dan halaman web dalam satu aplikasi. 

Untuk menghasilkan website yang profesional dan elegan, Fireworks  

harus dikombinasikan penggunaannya sesuai dengan peruntukan dan 

fitur unik masing-masing aplikasi. Pada bagian berikutnya kita akan 

melihat beberapa teknologi yang dapat dijadikan alternatif maupun 

pelengkap Macromedia Fireworks. 

B. Teknologi alternatif 

Tujuan utama Fireworks adalah untuk menghasilkan website. Perangkat 

alternatif untuk mencapai tujuan tersebut antara lain: 

 Microsoft FrontPage 

 Macromedia Dreamweaver 

Microsoft FrontPage 

Merupakan produk Microsoft, memungkinkan desainer membuat website 

dengan interface grafis.  

1.  Kelebihan : 

 Penggunaan sederhana dan mudah 

 Kebutuhan sistem lebih rendah daripada Fireworks dan Dreamweaver 
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2.  Kekurangan : 

 Tidak dapat menampilkan Applet pada saat editing. 

 Tidak punya fitur integrasi dengan database backend 

 Tidak punya kemampuan image-editing 

 Tidak punya kemampuan membuat animasi dengan image 

 Dukungan JavaScript dan CSS minim. 

Macromedia Dreamweaver 

1.  Kelebihan : 

 Dapat membuat website yang langsung terintegrasi dengan database 

backend. 

 Dapat menampilkan Java Applets dan ActiveX secara langsung pada 

saat editing. 

 Mempunyai fitur otomasi JavaScript 

 Mempunyai fitur otomasi CSS 

2.  Kelemahan :  

 Kebutuhan sistem lebih tinggi daripada FrontPage 

 Penggunaan relatif lebih kompleks dan sulit 

 Tidak punya kemampuan image editing 

Macromedia Fireworks  

1.  Kelebihan : 

 Mempunyai kemampuan text formatting yang lengkap 

 Mempunyai kemampuan image manipulation  

 Mempunyai kemampuan membuat animasi 

2.  Kelemahan : 

 Tidak punya integrasi dengan database. 

 Membutuhkan latar belakang pengetahuan image editing 
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II. Teknik Dasar Fireworks 

A. Membuat button sederhana 

Object adalah semua komponen yang ada di dalam area kerja. Object 

dapat berupa text, bentuk geometris (kotak, lingkaran, dsb), dan image. 

Sekarang kita akan membuat tombol yang mempunyai efek animasi 

sederhana.  

Membuat object 

Object dibuat dengan menggunakan toolbar di sebelah kiri.  

1.  Klik tombol untuk membuat kotak. 

 

2.  Klik tombol kiri mouse dan tahan di area kerja. 
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3.  Lepaskan tombol mouse 

 

B. Menggunakan object 

Memilih object 

Object dipilih dengan menggunakan beberapa tools yaitu: 

Pointer Tool 

Digunakan untuk memilih satu blok object yang terkumpul 

dalam satu area. 

Subselection Tool 

Digunakan untuk memilih satu object tertentu dalam grup 

 

 

Select Behind Tool  

Digunakan untuk memilih object yang berada di belakang 

object lain. 

 

Export Area 

Digunakan untuk memilih object yang berada di belakang 

object lain. 

 

Mewarnai object 

Ada dua fasilitas yang berkaitan dengan warna, yaitu fill dan stroke. Fill 

adalah warna di dalam object, sedangkan stroke adalah warna garis tepi 

object. Selanjutnya kita akan memperhalus tombol yang baru saja dibuat. 

1.  Klik object dengan pointer tool. 

Object yang dalam kondisi dipilih akan ditandai dengan garis biru. 
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2.  Klik tombol stroke, dan pilih warna yang sesuai. 

Tombol Stroke ada pada toolbar di sebelah kiri. 

 

 

3.  Buka Stroke Inspector melalui Window > Stroke 

Stroke 

Fill 
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4.  Atur tipe stroke, ketebalan, dan konfigurasi 
lainnya. 

 

Object kotak sekarang telah memiliki garis tepi.  

Selanjutnya, kita akan mengisi warna di dalam kotak. 

5.  Buka Fill Inspector melalui Window > Fill 

6.  Atur warna dan efek pewarnaan melalui Fill 
Inspector. 

Menambahkan efek pewarnaan 

Kotak yang telah diwarnai tersebut dapat diberikan efek tambahan untuk 

menciptakan kesan tiga dimensi.  

1.  Buka Effect Inspector melalui Window > Effect 

Effect Inspector akan menampilkan kotak kosong, karena belum ada efek 

yang ditambahkan.  
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Pilih efek yang sesuai, kali ini kita akan menggunakan Inner Bevel 

2.  Klik pemilih effect, pilih Bevel and Emboss > Inner 
Bevel 

 

 

Konfigurasi Inner Bevel muncul, sesuaikan pengaturannya dengan 

screenshot. 

 

3.  Klik di tempat kosong untuk mengakhiri edit 
effect.  

 

Sebuah object dapat dipasangi lebih dari satu effect. Berikutnya kita akan 

menambahkan Drop Shadow. 
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4.  Klik tombol pemilih effect, pilih Shadow and Glow 
> Drop Shadow. 

5.  Atur konfigurasi Drop Shadow 

Mengubah object menjadi button 

Selanjutnya, kita akan mengubah kotak yang telah didekorasi tersebut 

menjadi tombol. Tombol adalah object khusus yang dapat bereaksi 

terhadap gerakan dan klik mouse.  

1.  Klik kotak dengan menggunakan pointer tools 

2.  Pada menu, klik Insert > Convert To Symbol 

3.  Pilih Button 

4.  Beri nama object 

5.  Klik OK 

 

Tombol kita akan berubah warna menjadi hijau.  

Jangan khawatir, warna asli tombol tetap seperti yang telah diatur 

sebelumnya. Warna hijau tersebut menandakan bahwa object tersebut 

merupakan object khusus yang bertipe Slice. Slice adalah object yang 

dapat bereaksi terhadap gerakan mouse dan mempunyai kemampuan 

untuk dioptimasi. Topik mengenai optimasi akan dibahas pada bagian 

lain.  
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Mengisi tulisan dalam tombol 

1.  Pada menu, klik Modify > Symbol > Edit Symbol 

2.  Klik tombol Add Text 

3.  Klik pada area kerja, dan tuliskan label Ini Tombol. 

Selanjutnya, kita akan meluruskan posisi tulisan dengan posisi tombol.  

4.  Klik tombol dengan pointer tool. 

5.  Tekan tombol Shift, tahan, kemudian klik tulisan 
Ini Tombol. 

6.  Atur kelurusan horizontal melalui Modify > Align > 
Center Horizontal 

7.  Atur kelurusan vertikal melalui Modify > Align > 
Center Vertical 

C. Membuat efek animasi  

Untuk membuat efek animasi pada button, ada beberapa langkah yang 

harus dilakukan. 

 

Perhatikan tabs pada bagian atas Button Editor: 

 Up 

Kondisi up adalah kondisi normal, tombol siap diklik. 

 Over 

Kondisi over terjadi apabila mouse pointer berada di atas tombol 

 Down 

Kondisi down terjadi apabila tombol sedang ditekan, misalnya pada 

toolbar.  

 Over While Down 

Kondisi ini terjadi apabila mouse pointer berada di atas tombol yang 

dalam posisi down. 
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Tab-tab tersebut menyatakan kondisi tombol yang mungkin terjadi pada 

saat digunakan.  

Selanjutnya, kita akan mengaktifkan efek Mouse Over, yaitu perubahan 

bentuk tombol apabila mouse pointer diletakkan di atas tombol. 

1.  Klik tab Over 

2.  Klik Copy Up Graphics 

Tombol Copy Up Graphics ini akan mengambil semua object pada tab 

Up. Object ini akan menjadi dasar pengeditan selanjutnya. 

Setelah itu, kita akan melakukan beberapa modifikasi pada button pada 

kondisi disorot MousePointer. 

3.  Klik tombol dengan Pointer Tools 

4.  Ganti warna latar belakang tombol 

5.  Klik tulisan dengan Pointer Tools 

6.  Ganti warna tulisan 

Selanjutnya, kita akan memberi efek pada kondisi Down dan Over While 

Down. 

7.  Klik tab Down 

8.  Klik Copy Over Graphics 

9.  Klik tombol dengan Pointer Tools 

10.  Ganti warna latar belakang tombol 

11.  Ganti efek tombol 

12.  Klik tulisan dengan Pointer Tools 

13.  Ganti warna tulisan 

14.  Lakukan hal yang sama untuk kondisi Over While 
Down 

15.  Tutup button editor 

16.  Lihat hasil animasi pada tab Preview 
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Duplikasi Object 

Duplikasi dilakukan untuk membuat object baru yang sama persis 

dengan object yang telah ada. Sekarang kita akan menduplikasi button 

yang baru saja dibuat. 

1.  Klik kiri dan tahan Ini Tombol dengan Pointer Tool 

2.  Geser posisi mouse pointer. 

3.  Tekan dan tahan tombol Alt 

4.  Lepaskan tombol mouse 

5.  Lepaskan tombol Alt 

Button yang baru saja dibuat harus disesuaikan labelnya agar berbeda 

dengan tombol yang lama. 

6.  Buka Object Inspector 

7.  Ganti tulisan pada kolom Button Text 

8.  Tekan tombol enter 

Akan muncul dialog box menanyakan apakah perubahan akan dilakukan 

pada seluruh button. Saat ini kita hanya akan mengubah tombol yang 

baru.  

9.  Pilih Current 
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III. Menggunakan image dengan 

FireWorks 

A. Mengimpor image 

Mengimpor image dilakukan untuk menggunakan file yang telah ada 

sebelumnya.  

1.  Klik File > Import 

2.  Pilih file yang akan diimpor 

 

Dialog box akan muncul, menampilkan option yang berkaitan dengan 

tipe file yang diimpor. 

3.  Klik OK 

Dengan langkah yang sama, import file latihan yang diberikan instruktur. 

B. Mengedit image 

Image dapat diedit pixel per pixel, dengan menggunakan langkah-

langkah berikut : 

Klik Modify > Image Object 

Edit gambar yang telah diimpor sesuai dengan petunjuk instruktur. 
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C. Menggunakan Frame  

Frame digunakan untuk menumpuk beberapa image pada lokasi yang 

sama. Kita akan menggunakan frame untuk menciptakan beberapa efek 

rollover. 

1.  Klik Windows > Frame untuk menampilkan Frame 
Inspector. 

2.  Klik New / Duplicate Frame 

 

 

3.  Tambahkan object baru pada frame yang baru. 

 

D. Menggunakan Frame 

Frame digunakan diantaranya untuk mengatur object yang tampil 

(visible) dan tidak tampil (invisible). Dengan cara ini, kita dapat 

menciptakan efek animasi. 

1.  Isi image pada berbagai layer. 

2.  Masuk ke layer pertama, pilih salah satu object 

3.  Gunakan slice, Insert > Slice 

Langkah ini akan membuat object menjadi Slice, yang nantinya akan 

berguna untuk melakukan efek pergantian (rollover). 

4.  Beri nama slide, gunakan Object Inspector. 
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Gunakan salah satu tombol untuk mengaktifkan pergantian frame. 

5.  Pilih salah satu button 

6.  Klik Window > Behaviour untuk menampilkan 
Behaviour Inspector 

7.  Tambahkan event pada button 

8.  Tentukan frame yang akan ditampilkan 

E. Optimasi Image 

Image yang akan digunakan dalam website sebaiknya mempunyai 

ukuran file yang kecil untuk mempercepat transfer data. Beberapa fitur 

Fireworks dapat digunakan untuk memperkecil ukuran file.  

1.  Pilih object yang akan dioptimasi 

2.  Tampilkan Optimize Inspector 
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3.  Atur setting optimasi image. 

4.  Lihat hasilnya dengan mengaktifkan 2-up tabs 

 

 

Kompresi ukuran file akan mengakibatkan penurunan kualitas gambar. 

Dengan membandingkan hasil optimasi dan gambar asli, kita dapat 

mengatur rasio ukuran file dan kualitas yang sesuai. 
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IV. Kombinasi dengan Aplikasi lainnya 

A. Output Fireworks  

Hasil pekerjaan yang telah dibuat dengan menggunakan Fireworks  

digabungkan dengan tools lainnya untuk menghasilkan website yang 

fungsional. Output Fireworks  ada beberapa jenis, diantaranya : 

 Kombinasi image dan JavaScript 

 Image beranimasi 

Jenis output ini tergantung object yang kita pilih, jenis perlakuan dan 

animasinya. 

B. Export file 

Untuk mengekspor hasil pekerjaan Fireworks ke dalam file, lakukan 

langkah-langkah berikut: 

1.  Klik File > Export 

Export dialog akan muncul.  

2.  Tentukan konfigurasi yang sesuai 

3.  Klik OK 
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Ada beberapa setting yang dapat dikonfigurasi. Beberapa yang penting 

adalah : 

 Slicing 

 Style 

 Location  

 

Slicing 

Menentukan slice yang akan diekspor. 

Style 

Mengoptimasi hasil ekspor untuk aplikasi tertentu. 

Location 

 Same Directory:  export HTML ke folder yang sama dengan  image 

files.  

 One Level Up : export HTML satu folder di atas image files. Ini adalah 

pilihan yang paling umum digunakan. 

 Custom : Menentukan sendiri lokasi hasil export 

 Copy to Clipboard : export HTML ke Clipboard sehingga siap di-paste 

di aplikasi lainnya. 

 

Lihat hasil export di folder yang ditentukan. HTML file yang dihasilkan 

dapat langsung dicopy dan dipaste di aplikasi yang berkaitan. 


